Advisory Details

May 12th, 2022

Foxit PDF Reader Doc Object Use-After-Free Remote Code Execution Vulnerability

ZDI-22-762
ZDI-CAN-16639

CVE ID CVE-2022-28671
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Foxit
AFFECTED PRODUCTS PDF Reader
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit PDF Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of Doc objects. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Foxit has issued an update to correct this vulnerability. More details can be found at:
https://www.foxit.com/support/security-bulletins.html
DISCLOSURE TIMELINE
  • 2022-03-02 - Vulnerability reported to vendor
  • 2022-05-12 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES