Advisory Details

May 27th, 2022

Cisco RV340 JSON RPC set-snmp Stack-based Buffer Overflow Remote Code Execution Vulnerability

ZDI-22-802
ZDI-CAN-15634

CVE ID CVE-2022-20753
CVSS SCORE 4.3, (AV:A/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L)
AFFECTED VENDORS Cisco
AFFECTED PRODUCTS RV340
VULNERABILITY DETAILS


This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of Cisco RV340 routers. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed.

The specific flaw exists within the handling of set-snmp JSON RPC requests. When parsing the usmUserAuthKey parameter, the process does not properly validate the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the www-data user.

ADDITIONAL DETAILS Cisco has issued an update to correct this vulnerability. More details can be found at:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-sbrv-rce-OYLQbL9u
DISCLOSURE TIMELINE
  • 2022-01-12 - Vulnerability reported to vendor
  • 2022-05-27 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES