Advisory Details

June 15th, 2022

Adobe Illustrator SVG File Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability

ZDI-22-818
ZDI-CAN-16444

CVE ID CVE-2022-30641, CVE-2022-30645
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Illustrator
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adobe Illustrator. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of SVG images. Crafted data in an SVG image can trigger a write past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
https://helpx.adobe.com/security/products/illustrator/apsb22-26.html
DISCLOSURE TIMELINE
  • 2022-02-04 - Vulnerability reported to vendor
  • 2022-06-15 - Coordinated public release of advisory
CREDIT Mat Powell of Trend Micro Zero Day Initiative
BACK TO ADVISORIES