Advisory Details

June 30th, 2022

Advantech iView updatePROMSelect SQL Injection Information Disclosure Vulnerability

ZDI-22-916
ZDI-CAN-16561

CVE ID CVE-2022-2135
CVSS SCORE 7.5, (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)
AFFECTED VENDORS Advantech
AFFECTED PRODUCTS iView
VULNERABILITY DETAILS

This vulnerability allows remote attackers to disclose sensitive information on affected installations of Advantech iView. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the NetworkServlet endpoint, which listens on TCP port 8080 by default. When parsing the PROMVERSION, BUILDDATE, and CREATE_DATE elements of the updatePROMSelect action, the process does not properly validate a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to disclose stored credentials, leading to further compromise.

ADDITIONAL DETAILS Advantech has issued an update to correct this vulnerability. More details can be found at:
https://www.cisa.gov/uscert/ics/advisories/icsa-22-179-03
DISCLOSURE TIMELINE
  • 2022-03-02 - Vulnerability reported to vendor
  • 2022-06-30 - Coordinated public release of advisory
CREDIT @rgod777
BACK TO ADVISORIES