Advisory Details

September 8th, 2023

PDF-XChange Editor J2K File Parsing Uninitialized Variable Information Disclosure Vulnerability

ZDI-23-1353
ZDI-CAN-20907

CVE ID CVE-2023-42046
CVSS SCORE 3.3, (AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N)
AFFECTED VENDORS PDF-XChange
AFFECTED PRODUCTS PDF-XChange Editor
VULNERABILITY DETAILS

This vulnerability allows remote attackers to disclose sensitive information on affected installations of PDF-XChange Editor. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of J2K files. The issue results from the lack of proper initialization of memory prior to accessing it. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of the current process.

ADDITIONAL DETAILS PDF-XChange has issued an update to correct this vulnerability. More details can be found at:
https://www.tracker-software.com/support/security-bulletins.html
DISCLOSURE TIMELINE
  • 2023-04-28 - Vulnerability reported to vendor
  • 2023-09-08 - Coordinated public release of advisory
CREDIT Mat Powell of Trend Micro Zero Day Initiative
BACK TO ADVISORIES