Advisory Details

November 14th, 2023

Siemens Tecnomatix Plant Simulation WRL File Parsing Type Confusion Remote Code Execution Vulnerability

ZDI-23-1628
ZDI-CAN-20840

CVE ID CVE-2023-38074
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Siemens
AFFECTED PRODUCTS Tecnomatix Plant Simulation
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Siemens Tecnomatix Plant Simulation. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of WRL files. The issue results from the lack of proper validation of user-supplied data, which can result in a type confusion condition. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Siemens has issued an update to correct this vulnerability. More details can be found at:
https://cert-portal.siemens.com/productcert/html/ssa-278349.html
DISCLOSURE TIMELINE
  • 2023-05-08 - Vulnerability reported to vendor
  • 2023-11-14 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES