Advisory Details

July 20th, 2023

Linux Kernel ksmbd Chained Request NULL Pointer Dereference Denial-of-Service Vulnerability

ZDI-23-979
ZDI-CAN-21165

CVE ID CVE-2023-3866
CVSS SCORE 5.9, AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
AFFECTED VENDORS Linux
AFFECTED PRODUCTS Kernel
VULNERABILITY DETAILS

This vulnerability allows remote attackers to create a denial-of-service condition on affected installations of Linux Kernel. Authentication is not required to exploit this vulnerability, but only systems with ksmbd enabled are vulnerable.

The specific flaw exists within the handling of chained requests. The issue results from dereferencing a NULL pointer. An attacker can leverage this vulnerability to create a denial-of-service condition on the system.

ADDITIONAL DETAILS Linux has issued an update to correct this vulnerability. More details can be found at:
https://lore.kernel.org/all/20230626180806.105257976@linuxfoundation.org/
DISCLOSURE TIMELINE
  • 2023-06-13 - Vulnerability reported to vendor
  • 2023-07-20 - Coordinated public release of advisory
  • 2023-07-28 - Advisory Updated
CREDIT Laurence Wit
BACK TO ADVISORIES