Advisory Details

May 19th, 2024

(Pwn2Own) QNAP TS-464 Exposed Dangerous Method Privilege Escalation Vulnerability

ZDI-24-474
ZDI-CAN-22495

CVE ID CVE-2024-32766
CVSS SCORE 6.5, AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
AFFECTED VENDORS QNAP
AFFECTED PRODUCTS TS-464
VULNERABILITY DETAILS

This vulnerability allows remote attackers to escalate privileges on affected installations of QNAP TS-464 NAS devices. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the privWizard.cgi endpoint. The issue results from an exposed dangerous method. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of root.

ADDITIONAL DETAILS QNAP has issued an update to correct this vulnerability. More details can be found at:
https://www.qnap.com/en/security-advisory/qsa-24-09
DISCLOSURE TIMELINE
  • 2023-11-15 - Vulnerability reported to vendor
  • 2024-05-19 - Coordinated public release of advisory
CREDIT Tri and Bien Pham (@bienpnn) from Team Orca of Sea Security
BACK TO ADVISORIES