Advisory Details

May 24th, 2024

Ivanti Endpoint Manager GetVulnerabilitiesDataTable SQL Injection Remote Code Execution Vulnerability

ZDI-24-514
ZDI-CAN-23549

CVE ID CVE-2024-29846
CVSS SCORE 7.2, AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
AFFECTED VENDORS Ivanti
AFFECTED PRODUCTS Endpoint Manager
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Ivanti Endpoint Manager. Authentication is required to exploit this vulnerability.

The specific flaw exists within the GetVulnerabilitiesDataTable method. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the service account.

ADDITIONAL DETAILS Ivanti has issued an update to correct this vulnerability. More details can be found at:
https://forums.ivanti.com/s/article/Security-Advisory-May-2024?language=en_US
DISCLOSURE TIMELINE
  • 2024-03-27 - Vulnerability reported to vendor
  • 2024-05-24 - Coordinated public release of advisory
CREDIT 06fe5fd2bc53027c4a3b7e395af0b850e7b8a044
BACK TO ADVISORIES