Advisory Details

June 10th, 2024

Trend Micro VPN Proxy One Pro Link Following Denial-of-Service Vulnerability

ZDI-24-585
ZDI-CAN-22715

CVE ID CVE-2024-36473
CVSS SCORE 5.3, AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
AFFECTED VENDORS Trend Micro
AFFECTED PRODUCTS VPN Proxy One Pro
VULNERABILITY DETAILS

This vulnerability allows local attackers to create a denial-of-service condition on affected installations of Trend Micro VPN Proxy One Pro. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the Vpn Background Controller. By creating a symbolic link, an attacker can abuse the application to create a file. An attacker can leverage this vulnerability to create a denial-of-service condition on the system.

ADDITIONAL DETAILS Trend Micro has issued an update to correct this vulnerability. More details can be found at:
https://helpcenter.trendmicro.com/en-us/article/tmka-07247
DISCLOSURE TIMELINE
  • 2024-01-28 - Vulnerability reported to vendor
  • 2024-06-10 - Coordinated public release of advisory
CREDIT Hashim Jawad (@ihack4falafel)
BACK TO ADVISORIES