Advisory Details

June 13th, 2024

Fuji Electric Tellus Lite V-Simulator 6 V10 File Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability

ZDI-24-681
ZDI-CAN-22747

CVE ID CVE-2024-37029
CVSS SCORE 7.8, AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
AFFECTED VENDORS Fuji Electric
AFFECTED PRODUCTS Tellus Lite
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Fuji Electric Tellus Lite. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of V10 files by the V-Simulator 6 module. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Fuji Electric has issued an update to correct this vulnerability. More details can be found at:
https://www.cisa.gov/news-events/ics-advisories/icsa-24-165-14
DISCLOSURE TIMELINE
  • 2024-01-11 - Vulnerability reported to vendor
  • 2024-06-13 - Coordinated public release of advisory
  • 2024-07-01 - Advisory Updated
CREDIT kimiya
BACK TO ADVISORIES